Horizon 3 AI Inc. - Pentest Scheduling/Provisioning Slow due to Third-Party Cloud Provider API Issues (AWS) – Incident details

Pentest Scheduling/Provisioning Slow due to Third-Party Cloud Provider API Issues (AWS)

Resolved
Degraded performance
Started 2 months agoLasted about 1 hour

Affected

H3

Degraded performance from 1:13 PM to 2:31 PM

Portal - US

Degraded performance from 1:13 PM to 2:31 PM

Scheduling Pentest

Degraded performance from 1:13 PM to 2:31 PM

Op Type - Internal

Degraded performance from 1:13 PM to 2:31 PM

Op Type - External

Degraded performance from 1:13 PM to 2:31 PM

Portal - EU

Degraded performance from 1:13 PM to 2:31 PM

Updates
  • Resolved
    Resolved

    Confirmed the issue has been fully resolved. All ops that had fully failed to provision have been recovered.

    We greatly appreciate your patience during incident!

  • Monitoring
    Monitoring

    AWS reports the API issues are resolved. We are continuing to monitor to confirm and working to resolve any ops to fully failed to schedule/provision.

  • Identified
    Identified

    We are experiencing an issues with an AWS API degradation that is causing all pentest op types to either be much slower then normal to provision or occasionally fail to provision entirely.

    We greatly appreciate your patience!